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Flu Appointment Search  Information  

This step -by -step guide will demonstrate how to produce a list of patients who have not 

booked an appointment for their flu vaccination in Vision and  show how to create a mail 

merge letter for those with no appointment using Microsoft Word and Excel  200 3. 

This guide presumes that you have read the step -by -step user guide in ñSetting up your 

workstation to import data from Vision into Microsoft Excel  20 03ò (as the FoxPro driver 

and Microsoft Query must be installed) and you are familiar with basic Vision searches  

and Microsoft Word and Excel .  

The instructions shown in this document are for those patients aged 65 and over , using 

an ad -hoc search. However,  you may use a group from clinical audit and import it into 

an ad -hoc search as well . 

You may also wish to run another search for those patients over 6m and under 65y in 

one or more risk categories  or use an audit group . However as the search criteria will  be 

the only difference it has not been written into this user guide.  

The process does not include special appointments, as these are free text appointments 

and cannot be cross referenced against the patient list extracted from the Vision search.  
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Settin g up the Vision Search 

Please feel free to vary the criteria of the search show below to suit your specific 

requirements . The  main objective of this search is to produce a list of patients that will 

require a flu vaccination.  

 

 

The example shows those  patients with an allergy to egg will be removed from the list of 

patients that require a flu vaccination. I t  presumes that the Allergy and Intolerence non 

drug entity  has been used  to record this data, please amend the search as nessassary if 

you record t his information elsewhere.  

 

Points to Note:  

 

Search Details:  

 You may prefer to use an exact Date of Birth instead of the formula shown above  

 Allergy and Intolerance non drug entity has (Exclude). This is done by right 

mouse clicking on this entity and selecting Options ;  select Exclude and remove 

the tick mark  (as shown above)  

Report  Details:  

 The Address entity has been added to the Report Details ONLY  (as shown above)  

 The Allergy and Intolerance non drug entity in Report Details has been set to 

(None). This is done by right mouse clicking on this entity and selecting Options : 

None  

 Report Output is set to Export Data (DBF File)  
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Run the Search 
When you click Run, you will be asked for a location to save the data, accept the default 

location (unless you w ant to use a different folder) and remember the folder location.  

Which will normally be C: \ Extract or P: \ Extract \ <usernumber>.<logon initials>  

 

Click OK to start the search  

Note: Please be patient as this may take sometime depending on the size of you pat ient 

list. This is because it also has to extract all the patient address details as well . 

The search is finished when the mouse pointer returns back to an arrow and not the 

hourglass, when hovered over the search window.  

Once complete you may close the se arch and open Microsoft Excel  

Microsoft Excel  

As mentioned at the beginning of this guide, the workstation must be set up once to 

import Vision data into Excel, if you have not done this please read the instructions 

ñSetting up your workstation to import data f rom Vision into Microsoft Excel 200 3ò which 

can be found at http://www.tailormadeit.co.uk/downloads.htm  under the heading: 

Exporting Search and Reports to Excel  

Note: if you are on the INPS Vi sion Enterprise solution (remote server), the relevant files 

will already be installed.  

Importing Vision Search Data  

1.  Click the cell A1, to set the focus.  

2.  Click the Data  tab > Import External Data > New Database Queryé 

 

 

http://www.tailormadeit.co.uk/downloads.htm
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3.  Highlight ñVisual FoxPro Databaseò in the list, click OK button 

 

 

4.  Either type the path of the folder location or use the Browse button to locate the 

folder where the Vision search data has been saved, as mentio ned earlier in ñRun 

the Searchò (Note: Free Table directory should be selected)  

 

 

5.  Click OK button to display the source data in the Query Wizard  

(Note: if you cannot see the exact same table s shown below , you have entered 

the wrong path . You may see more tables in the list , but these two are the 

important tables  for our current query )  
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Note :  that if you see this message when clicking the OK button  

The folder cannot be found: either check your spelling or use the browse button  

 

 

6.  Expand the ñpatientò table first (by clicking on the plus + sign)  

7.  Then double -click ñpat_id, title, forname1, surname and dobò so that they  jump 

across to the right window, as shown below. (Note: pat_id must be the first 

entry in the list ) use the up/down arrows to change the order of your selections  

 

 

8.  Now expand ñnewaddò to double -click ñhouse_name, house_no, road_name, 

local_name, town_name, county_nam and postcodeò so that they jump across to 

the right window. These will be needed for the  letter mail merge later .  

(Note: you do not need to add pat_id from this table)  

 

 



CrossC  

bradley@tailormadeit.co.uk   Page 7  of 18  www.tailormadeit.co.uk/vision.htm   

 

Flu Appointment Cross Reference Search  

9.  Click Next button  

10.  A warning message will be displayed, because you have selected fields from two 

or more different tables and Excel does not know what the unique item is in each 

table that will join the data.   

 

 

11.  Click OK and Microsoft Query will open  

 

 

12.  Two tables are shown  above the columns 

ñnewaddò and ñpatientò. Scroll down each 

list and locate ñpat_idò. 

13.  Then drag one pat_id across into the 

other table  and drop it on the other 

pat_id . 

If you have done this correctly a thin line 

will join the two items between the tables  

as shown  
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14.  This has now sorted all the data from the two tables and aligned the correct 

address fields to the patient details.  

15.  Click the File menu and Return Data to Microsoft Excel  

 

 

16.  Click OK button (as shown below)to paste the contents in the top most  corner of 

the spreadsheet  

 

 

You now have a list of all patients over 65 years with their address details  
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Importing Appointment Data  

1.  Click Sheet 2 tab located at the bottom of the workbook  

 

 

2.  Click the Data  tab > Import External Data > New Database Que ryé 

 

 

3.  Highlight ñVisual FoxPro Databaseò in the list, click OK button 

 

 

4.  Either type ñp:\ò in the path text box (as shown below) or use the Browse button 

to locate the P: \  drive (Note: Free Table directory should be selected)  

 

5.  Click OK button  
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6.  This will now display all the Vision databases; Scroll down to the SLOTAPP table  

 

 

7.  Expand ñslotappò table (by clicking on the plus + sign)  and double click each 

required field so that it jumps across to the right window, as shown above. 

(Note: pat_id must be the first entry in the list ) use the up/down arrows to 

change the order of your selections  

Note:  

 pat_label =  Patient details  

 slotdate & time =  Appointment Date and Time  

 staff_id =  Book Owner  

 count =  Appointment (1 = Booked)  

8.  Click Next  

The appointment data is much to big to import into excel  as a whole , therefore we are 

only going to import a specific date period and only appointments slots that have been 

filled by a patient name.  

9.  Highlight ñslotdateò and select ñis greater than or equal toò from the drop down 

list, then type in the date period in reverse as shown below: (YYYYMMDD)  
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10.  Now highlight ñcountò, select ñequalsò and type 1 as shown below 

 

 

If you have used a specific book owner/ clinic in your appointment system  to record all 

the flu appoin tments under , you may want to enter the Alias name in the staff_id to help 

define you data further. However this is not mandatory as we can filter i t out once the 

data is in Excel. Alternatively, you 

may wish to search all future 

appointments for these par ticular 

patients, in which case skip the 

staff_id step.  

If you want to find the Alias name 

from your appointment system, 

click the Maintenance menu and 

select Book Owners as shown 

below:  

 

 

11.  Highlight ñstaff_idò, select ñequalsò and type <alias> as shown below  
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12.  Click Next button  

13.  Select ñpat_idò from the sort list in Ascending  order  

(Note: this is an important step , so please do not skip it otherwise the 

procedure will not work)  

 

14.  Click Next button  

 

15.  Click Finish button to Return the data to Microsoft Office Excel  

16.  Click OK button (as shown below)to paste the contents in the top most corner of 

the spreadsheet  
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The appointment data is now in the spreadsheet, however we need to convert ñpat_idò 

into a recognised number format that Excel can read, as the F oxPro database stores it as 

text.  

17.  Highlight any number in the ñcountò column (i.e. 1) and ® click Copy  this cell  

 

 

18.  Click on the A column letter, to highlight the whole pat_id column, then right 

mouse click and select ñPaste Special éò (NOT Paste) 

 

 

19.  Select ñMultiplyò from the Operation section, click OK 
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Excel formula to find appointments for patients  

You have now successfully imported all the relevant data into two separate spreadsheets  

within the Excel workbook:  

 Sheet 1 has all the patients over 65y ( that require a flu vaccinatio n)  

 Sheet 2 has all the patients that have already booked a future appointment  

We now need to cross reference this data:  

1.  Select Sheet 1 tab  

 

2.  Scroll to the last column in the spreadsheet and type ñAppointmentò in the first 

row  header i.e. row 1 (as shown below )  

 
 

3.  Click into the next cell (row) under Appointment and type in this exact formula  

=IF(ISERROR(VLOOKUP(A:A,Sheet2!A:A,1,FALSE)),"N","Y")  

(You can just copy the above code and paste it into the cell)  

4.  You must now drag this formula down to every cell, by moving the mouse pointer 

to the bottom right corner of the cell until it changes to a crosshair (+), then hold 

down the left mouse button and drag down to the last cell in the range  

5.  It will now display :  

 Y  if there is a matching patient appointment  

 N  if there is no  appointment  

6.  Click any cell in the list to un -highlight the appointment column, then c lick the 

Data menu > Filter > AutoFilter  

 

7.  Click the Appointment Filter button and select N from the list to only show 

patients with no appointment.  
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8.  Highlight the Appointment column (by clicking the column letter i.e. ñLò as shown 

in the image) to view the Count :  at the bottom of the spreadsheet (minus 1 as it 

will count the header as well)  

 

9.  Save your Workbook in a f older by clicking the Save button or Ctrl+S on the 

keyboard . (Note: Please remember the folder location)  

 

 

10.  Close  the Workbook  
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Microsoft Word  

Mail Merge  Template Letter  

1.  Open Microsoft Word  

2.  If you have a Practice Letterhead document open this  now or we will just type the 

letter out now  

3.  Click ñToolsò tab  > Letters and Mailings > Mail Merge é 

 

 

4.  Select document type: Letter s 

 

 
 

5.  Click Next: Starting document (for the next step)  

6.  Select ñUse the current 

document ò (click Next : Select 

recipient s)  

7.  Select ñUse an existing list ò, 

and then click the Browse 

button to locate the Excel 

spreadsheet you saved earlier.  

Click Open button when 

located  

8.  Highlight:  Sheet 1 $, click OK 

button  


